February 02, 2014, 01:23:00 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
   Home   Help Search Login Register  
Pages: [1]
Author Topic: How to run s3sync as root ?  (Read 3160 times)
Posts: 3

View Profile
« on: January 07, 2008, 05:16:29 PM »

I'm creating a web interface for the s3sync to use it as a backup system of servers on S3. I'm facing a problem that apache doesn't have root privileges, so it can't access some directories . So I tried using sudo but it failed. somehow when I run the s3sync scrips using sudo and see the UID of the resulting process I find it the normal user not running as root. Any idea how can I use sudo with s3sync ?? or how to run the s3sync from my web interface as root ?? I'm not really a ruby guy

Ahmed Abdalla
Redhat Systems Engineer
« Last Edit: January 08, 2008, 05:06:10 PM by Abd4llA » Logged
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!