General Category => Report Bugs => Topic started by: uwes on February 21, 2008, 04:18:18 AM

Title: Unable to use EU buckets
Post by: uwes on February 21, 2008, 04:18:18 AM
I've been using s3sync/s3cmd for a while now, and I tried to switch everything to EU buckets after it worked on US buckets. I thought adding "EU" to the bucket commands and setting the calling format to SUBDOMAIN would do the trick.

However, I found that uploading to those buckets lasts incredibly long while running at high bandwidth. When I upload a 100 MB file, it's still not on the amazon server when about 200 or 300 MB have been uploaded. Even stranger: after the time it would about take to upload the file, s3cmd.rb informs me about a
temporary redirect. But still, nothing happens.

I have uploaded about 10 GB (!) to EU buckets, and amazon shows only some 500 MB activity. None of the files has ever reached its destination. I then skipped the "EU" constraint and switched the calling format back to regular - and everything worked like a charm.

Is there any explanation for this behavior?

I'm doing all my uploads with the --ssl option set, just in case this information is important.