February 02, 2014, 01:32:33 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
  Home Help Search Login Register  
  Show Posts
Pages: [1]
1  General Category / Questions / Re: "You didn't set up your environment variable" error on: March 24, 2008, 04:29:12 PM
brilliant! worked perfectly - many thanks.
2  General Category / Questions / "You didn't set up your environment variable" error on: February 29, 2008, 11:47:33 AM
Hi All,

Let me start by saying that I think I'm in at least a couple inches over my head here, but I'd like to get this working. I'm getting the following error:

You didn't set up your environment variables; see README.txt
s3sync.rb [options] <source> <destination>              version 1.2.4
 --help    -h          --verbose     -v     --dryrun    -n
 --ssl     -s          --recursive   -r     --delete
 --public-read -p      --expires="<exp>"    --cache-control="<cc>"
 --exclude="<regexp>"  --progress           --debug   -d
One of <source> or <destination> must be of S3 format, the other a local path.
* An S3 formatted item with bucket 'mybucket' and prefix 'mypre' looks like:
* Local paths should always use forward slashes '/' even on Windows
* Whether you use a trailing slash on the source path makes a difference.
* For examples see README.

I can't figure out where I'm supposed to enter that info. I'm using the method from this post: http://robrohan.com/2007/11/03/server-backup-with-amazon-s3-howto/, and I have my access keys in a separate .yml file. Many thanks for any help.
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!