General Category => Questions => Topic started by: TeckniX on June 12, 2008, 03:57:31 PM

Title: s3sync error with ruby 1.8.7 - SOLVED!
Post by: TeckniX on June 12, 2008, 03:57:31 PM
I have two machines with ruby and s3sync installed.

One has ruby 1.8.6 and can run s3sync without any problems
The other has ruby 1.8.7 and can't run s3sync commands - it outputs the following:
./s3cmd.rb listbuckets
./S3.rb:14:in `require': no such file to load -- openssl (LoadError)
        from ./S3.rb:14
        from ./s3try.rb:26:in `require'
        from ./s3try.rb:26
        from ./s3cmd.rb:16:in `require'
        from ./s3cmd.rb:16
I've read from a previous post that libopenssl-ruby was 'needed' yet I never had to install it on the other machine, which is a carbon copy of this one. The only difference between the two is the version of Ruby.

Anyone else experiencing this?

Title: Re: s3sync error with ruby 1.8.7 - Solution
Post by: TeckniX on June 13, 2008, 02:50:16 PM
My original issue was using 1.8.7 and my ssl not working.
I chanced it and compiled 1.8.6 and installed it, which seems to have overwritten the 1.8.7 since i'm now showing 1.8.6 as the ruby version.
What's beyond my understanding is that every document says it's built with ssl support by default, yet mine never worked.
I finally found a blog from someone creating solaris packages, explaining that separate extensions could be compiled after wards, as follow:
- in the ruby source directory type:
[ruby-1.8.6]#cd ext/openssl
- there's a ruby file 'extconf.rb' that can be ran as such:
[ruby-1.8.6]#ruby extconf.rb
- ruby will build a Makefile that will be needed to build the libraries:
[ruby-1.8.6]#make install
That's it! Now where is this information in the README? I didn't think to look in the documentation, but some google of ruby openssl really didn't show anything at all.