General Category => Questions => Topic started by: phillc on November 08, 2007, 05:19:29 PM

Title: S3 ERROR: #<Net::HTTPMovedPermanently:0xb7900404>
Post by: phillc on November 08, 2007, 05:19:29 PM
I'm sorry that my first post on here has to be about a problem I have with s3sync.

I've only just installed it and am very new. I've been following the instructions here:


And I am getting an error with when executing upload.sh script. I also tried putting my environment variables into an s3config.yml file but am getting the same error.

Here it is:

ruby s3sync.rb -r --dryrun /root/s3synctest/ kapitalmototv:/kmtv

S3 command failed:
list_bucket kapitalmototv max-keys 200 prefix /kmtv delimiter /
With result 301 Moved Permanently
S3 ERROR: #<Net::HTTPMovedPermanently:0xb7900404>
s3sync.rb:292:in `+': can't convert nil into Array (TypeError)
        from s3sync.rb:292:in `s3TreeRecurse'
        from s3sync.rb:348:in `main'
        from ./thread_generator.rb:79:in `call'
        from ./thread_generator.rb:79:in `initialize'
        from ./thread_generator.rb:76:in `new'
        from ./thread_generator.rb:76:in `initialize'
        from s3sync.rb:269:in `new'
        from s3sync.rb:269:in `main'
        from s3sync.rb:708

Any ideas because I have none!

Title: Re: S3 ERROR: #<Net::HTTPMovedPermanently:0xb7900404>
Post by: phillc on November 08, 2007, 05:56:00 PM
Having just read a little further, I'm guessing my problem is because I created a European bucket, similar to what is discussed in this thread:


I didn't really understand if a fix had been made though?

Title: Re: S3 ERROR: #<Net::HTTPMovedPermanently:0xb7900404>
Post by: Clou on November 09, 2007, 04:17:14 AM
No fix is available yet. AFAIK.


Title: Re: S3 ERROR: #<Net::HTTPMovedPermanently:0xb7900404>
Post by: maelcum on November 19, 2007, 01:10:23 PM
You need a new version. EU-buckets are quite new.
Here's a beta available: http://s3sync.net/forum/index.php?topic=106.msg436#msg436